【经历】linux安装jdk1.7和环境配置

发布于 2015-05-28  572 次阅读


起因

感觉已经好久好久没有安装这个了。这次为了安装一个秒杀平台,原先的生产环境是jdk1.6的,也就没有去升级它。直接把他们用1.7编译的项目放上去之后,就会报错了,链接不上数据库,报错内容是:

oracle/jdbc/driver/OracleDriver : Unsupported major.minor version 51.0

原因就是jdk不匹配,有两个方法,一个就是编译的使用换用1.6的jdk,一个就是服务端用1.7的jdk,这样就可以正常运行了。

安装jdk1.7

进入linux系统后

第一步确认是否有安装着jdk,使用java -version 可以查看jdk版本

[root@localhost java]# rpm -qa|grep gcj 或者 rpm -qa|grep java
libgcj-4.1.2-44.el5
java-1.4.2-gcj-compat-1.4.2.0-40jpp.115

如果没有信息就是没有安装、如果有那么如下操作

[root@localhost jdk-6u13-linux-i586]# yum -y remove java-1.4.2-gcj-compat-1.4.2.0-40jpp.115

或者

[root@localhost jdk-6u13-linux-i586]# rpm -e --nodeps java-1.4.2-gcj-compat-1.4.2.0-40jpp.115

卸载之后,去下载jdk,可以选择官方下载,官方下载地址:

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-downloads-javase7-521261.html

也可以通过我下载下来放在网盘的地址下载(只有32位的,优势是网盘速度比官方快),地址:

http://pan.baidu.com/s/1o6C96rg

下载之后安装(我选择rpm包安装):

[root@localhost local]# rpm -ivh jdk-7-linux-i586.rpm

Preparing...                ########################################### [100%]
1:jdk                            ########################################### [100%]
Unpacking JAR files...
rt.jar...
jsse.jar...
charsets.jar...
tools.jar...
localedata.jar...
plugin.jar...
javaws.jar...
deploy.jar...

很简单,这样子就安装好了

配置环境变量

设置环境变量(写入/etc/profile中) (路径自己去校对过

vi /etc/profile

增加下面语句

JAVA_HOME=/usr/java/jdk1.6.0_27
PATH=$PATH:$JAVA_HOME/bin:$JAVA_HOME/jre/bin
CLASSPATH=.:$JAVA_HOME/lib:$JAVA_HOME/jre/lib:$CLASSPATH
export PATH USER LOGNAME MAIL HOSTNAME HISTSIZE INPUTRC JAVA_HOME CLASSPATH

执行

source /etc/profile

注销,并重新登录

okay了键入 java -version 如果出现相关JDK版本信息,证明成功.

假如出现版本太多的问题(原因就是没有最先删除已经存在版本)

版本太多默认哪个的问题(路径自己校对):

sudo update-alternatives --install /usr/bin/java java /usr/java/jdk1.6.0_27/bin/java 300

sudo update-alternatives --install /usr/bin/javac javac /usr/java/jdk1.6.0_27/bin/javac 300

执行代码:

sudo update-alternatives --config java

好了,简陋的教程到此为止,希望你一切顺利

 


生命旅客,闷头赶路总不太可取,留一刻给那可爱可敬的人,留一眼给那靓丽迷人之景,也请善待自己~